New and Used Car Talk Reviews Hot Cars Comparison Automotive Community

The Largest Car Forum in the Philippines



Page 115 of 177 FirstFirst ... 1565105111112113114115116117118119125165 ... LastLast
Results 1,141 to 1,150 of 1770
  1. Join Date
    Apr 2008
    Posts
    2,254
    #1141
    low speed kasi xwind natin.. kaya parang nageengine break hehehe.. pitik pitik lang bro madadali mo din ung 140kph kumabaga wag ka magdiin alalay lang unti unti

  2. Join Date
    Nov 2005
    Posts
    7,501
    #1142
    korek si Kevin! ayaw ng old school diesel ng nalulunod, nagtatampo at ayaw mag respond hahaha pero pag binitin bitin mo sa bigay ng diesel naku! galit na galit at gustong gusto.....ayaw lang nila maniwala eh :bwahaha:

  3. Join Date
    Oct 2007
    Posts
    29
    #1143
    yo guys, happy new year to all xwind owners out there.
    ung aking 09xuv, after ng 1500 pms nya, i tried ihataw sa nlex, napa-abot ko hanggang 130kph bukas ang aircon, mas smooth pa nga ang takbo kesa sa low-speed.
    wala tayo magagawa sa vibrations kasi nga timing 'gear' sila, and nasa low-end ang gearing ratio kaya medyo mabagal pumik-up pero malakas ang tourque nya(utility vehicle talaga)pero hinay-hinay lang guys sa pagpapatakbo, better safe than sorry dba?
    alagaan na lang natin mga xwinds natin, para wag madurog ang makina at mag-serbisyo sya nang matagal, and hanga talaga ako sa tipid nila, palagay ko nothing can beat isuzu on that.
    mabuhay ang isuzu owners.........

  4. Join Date
    Jan 2010
    Posts
    12
    #1144
    gud pm, bago lang po ako dito, ask ko lang yung problema na crosswind xuvi ko, model 2005, nag on na lang bigla ang break light, di naman nakaandar, pati yung park light naka off , i tried i off sa remote di naman na off, kaya ang ginawa ko tinanggal ko na lang ang fuse, nung binalik ko ulit, same story ayaw ulit mag off ang break light ano kaya ang problema nun, salamat...

  5. Join Date
    Sep 2009
    Posts
    4,593
    #1145
    Quote Originally Posted by ramledi View Post
    kung green po na two tone na may window visor pwedeng ako yun. pero nakasara parati bintana ko at 70kph lang takbo ko sa gabi. wahahaha

    oo maitim ang usok kapag nasa ganon na ang speed pero nawawala rin kapag naibuga na yung mga excess na carbon.
    parang maroon ata yung naaalala ko. pero bow ako sa oldskul mo bro. baka talo pa xto ko! ride safe!

  6. Join Date
    Feb 2005
    Posts
    2,642
    #1146
    Quote Originally Posted by renzzalen View Post
    gud pm, bago lang po ako dito, ask ko lang yung problema na crosswind xuvi ko, model 2005, nag on na lang bigla ang break light, di naman nakaandar, pati yung park light naka off , i tried i off sa remote di naman na off, kaya ang ginawa ko tinanggal ko na lang ang fuse, nung binalik ko ulit, same story ayaw ulit mag off ang break light ano kaya ang problema nun, salamat...
    Have you owned this XUVi since new or was it bought 2nd hand? Reason I'm asking is baka may grounded na wire that causes this "glitch"... specially if 2nd hand nyo nabili yan, you would not exactly know what mods the previous owner did on the car that may be causing this.

    Eitherway, I would still recommend you to have your Crosswind checked by a trusted and reputable electrician/shop. Electrical yan... not something to belittle.

  7. Join Date
    Mar 2009
    Posts
    1,422
    #1147
    Quote Originally Posted by Benzmizer View Post
    Have you owned this XUVi since new or was it bought 2nd hand? Reason I'm asking is baka may grounded na wire that causes this "glitch"... specially if 2nd hand nyo nabili yan, you would not exactly know what mods the previous owner did on the car that may be causing this.

    Eitherway, I would still recommend you to have your Crosswind checked by a trusted and reputable electrician/shop. Electrical yan... not something to belittle.
    *Bob you got pm.

  8. Join Date
    Jun 2009
    Posts
    288
    #1148
    Quote Originally Posted by holdencaulfield View Post
    parang maroon ata yung naaalala ko. pero bow ako sa oldskul mo bro. baka talo pa xto ko! ride safe!

    thanks bro. hataw lang lang naman ako kapag clear ang daan. 70kph lang naman average speed ko parati. pinipiga ko lang para matanggal yung excess na carbon kapag may pagkakataon.

  9. Join Date
    Jan 2010
    Posts
    12
    #1149
    thank you so much po sa info, dadalhin ko na lang sya sa electrician.

  10. Join Date
    Sep 2007
    Posts
    126
    #1150
    Quote Originally Posted by renzzalen View Post
    gud pm, bago lang po ako dito, ask ko lang yung problema na crosswind xuvi ko, model 2005, nag on na lang bigla ang break light, di naman nakaandar, pati yung park light naka off , i tried i off sa remote di naman na off, kaya ang ginawa ko tinanggal ko na lang ang fuse, nung binalik ko ulit, same story ayaw ulit mag off ang break light ano kaya ang problema nun, salamat...
    check the brake pedal. there should be a push switch near its other end that when the brake pedal is not pressed, the switch should be pressed. normally, merong rubber thing na nakadikit dun sa brake pedal arm mo that depresses that switch, sometimes due to old age, kumukunat yun and nadudurog. check mo yun baka natanggal na. I encountered this problem with my civic last year and what I did was to put a screw in place of the rubber thing. That solved the problem pero medyo may tunog lang pag bigla ko binibitiwan yung pedal. In any case, call mo na kung reremedyuhan mo na lang or dadalin sa casa to buy the OEM part. goodluck!

Tags for this Thread

Isuzu Crosswind Owners Thread [ARCHIVED]