New and Used Car Talk Reviews Hot Cars Comparison Automotive Community

The Largest Car Forum in the Philippines



Page 63 of 64 FirstFirst ... 1353596061626364 LastLast
Results 621 to 630 of 640
  1. Join Date
    Feb 2012
    Posts
    605
    #621
    Quote Originally Posted by natelopez View Post
    Mga sir hinge sana ako ng advice kc ang crosswind xt 2012 model ko ay mausok po at mahina ang hatak... Ano po pwde ko gawin dun? May kilala po ba kayo mekaniko? Taga alabang lang po ako salamat po
    baka po madumi na ang fuel filter sir...

  2. Join Date
    Jan 2011
    Posts
    642
    #622
    disable EGR and use 2t oil. super effective yan.

  3. Join Date
    Jan 2014
    Posts
    2,606
    #623
    Quote Originally Posted by natelopez View Post
    Mga sir hinge sana ako ng advice kc ang crosswind xt 2012 model ko ay mausok po at mahina ang hatak... Ano po pwde ko gawin dun? May kilala po ba kayo mekaniko? Taga alabang lang po ako salamat po
    Pina pa PMS niyo po ba sa casa yung crosswind xt niyo?

  4. Join Date
    Oct 2005
    Posts
    5,465
    #624

  5. Join Date
    Oct 2007
    Posts
    43
    #625
    gud pm mga sirs. fit ba ang sportivo front seats sa crosswind? diba bucket seats na ang sa sportivo?

  6. Join Date
    Jan 2014
    Posts
    2,606
    #626
    Quote Originally Posted by iandvo View Post
    gud pm mga sirs. fit ba ang sportivo front seats sa crosswind? diba bucket seats na ang sa sportivo?
    yes po kasya yan
    remeber during nung may xuv saka sportivo noong
    2005
    bench yung sa harap para sa xuv at sportivo bucket
    same dimension lang yan sir
    palagyan mo nalng centerconsole para wala space sa gitna
    btw ano po yung crosswind nyo?

  7. Join Date
    Dec 2010
    Posts
    3
    #627
    good evening mga sir! first post ko to. I have been a lurker dito for quite sometime now. May tanong ako regarding my XUV. minsan napansin ko if I will start the SUV hindi siya mag start pero naka on lahat ng lights. Then I will just turn off and then start it again and the engine will now start. Symptom kaya ito ng something bad soon? Thanks in advance sa mga sasagot (y)

  8. Join Date
    Apr 2015
    Posts
    4
    #628
    Hi,

    Ask ko lang kung pano ba mababawasany ung sensitivity nung alarm, Sportivo 2007 po yung sasakyan. nasa tabing daan lang po kasi nakaparada and may madaan lang ng motor kahit di naman malakas yung arangkada nag aalarm sya.

    Salamat.

    - - - - - - - - - - - - - - - - - - - - - -

    Hi,

    Ask ko lang kung pano ba mababawasany ung sensitivity nung alarm, Sportivo 2007 po yung sasakyan. nasa tabing daan lang po kasi nakaparada and may madaan lang ng motor kahit di naman malakas yung arangkada nag aalarm sya.

    Salamat.

  9. Join Date
    Jul 2008
    Posts
    398
    #629
    Quote Originally Posted by istoryamember View Post
    good evening mga sir! first post ko to. I have been a lurker dito for quite sometime now. May tanong ako regarding my XUV. minsan napansin ko if I will start the SUV hindi siya mag start pero naka on lahat ng lights. Then I will just turn off and then start it again and the engine will now start. Symptom kaya ito ng something bad soon? Thanks in advance sa mga sasagot (y)
    every time you start the engine, gumagana kasi ang mga glow plugs para initin ang cold makina. baka lang, you need to let the glow plugs heat the engine 2x. possible din, bigay na ang isa sa apat na glow plugs

  10. Join Date
    Nov 2014
    Posts
    17
    #630
    Quote Originally Posted by kevinworld View Post
    every time you start the engine, gumagana kasi ang mga glow plugs para initin ang cold makina. baka lang, you need to let the glow plugs heat the engine 2x. possible din, bigay na ang isa sa apat na glow plugs
    Walang glow plug unit natin. supposed to be one click lang yon. Try to check the starter solenoid.

    - - - - - - - - - - - - - - - - - - - - - -

    Quote Originally Posted by kevinworld View Post
    every time you start the engine, gumagana kasi ang mga glow plugs para initin ang cold makina. baka lang, you need to let the glow plugs heat the engine 2x. possible din, bigay na ang isa sa apat na glow plugs
    Walang glow plug unit natin. supposed to be one click lang yon. Try to check the starter solenoid.

Isuzu Crosswind XUV/XUVi Owners