New and Used Car Talk Reviews Hot Cars Comparison Automotive Community

The Largest Car Forum in the Philippines



Page 2 of 16 FirstFirst 12345612 ... LastLast
Results 11 to 20 of 154
  1. Join Date
    Oct 2002
    Posts
    696
    #11
    Quote Originally Posted by kimpOy
    Asian Utility Vehicles
    and I always thought ALL Utility Vehicle... parang for all-around... :shock: 8)

  2. Join Date
    Oct 2002
    Posts
    1,115
    #12
    Skywalker,

    Xuv AT 7-8 km/l, mahina arangkada... not too happy about it

  3. Join Date
    Oct 2002
    Posts
    232
    #13
    Quote Originally Posted by dieselNUBI
    Skywalker,

    Xuv AT 7-8 km/l, mahina arangkada... not too happy about it
    Ganoon ba? Di ba may turbo yan, di ba na compensate ang AT?

    Mine is a MT and I'm satisfied with the acceleration and power. 10km/li ang average fuel consumption ko.

  4. Join Date
    Oct 2002
    Posts
    1,115
    #14
    sky,

    Turbo does it job well... it turns on at 60

    but below 60... parang hirap tumakbo... pigiil ang feeling...
    also when running at medium speeds lets say 30-40, pag nag slow down, then when i try to accelerate again... ayun hirap arangkada...

    feeling ko un pagka pigil nang takbo ko makes it 7-8km/L

  5. Join Date
    Oct 2002
    Posts
    1,058
    #15
    i've also a crosswind and and xuvi variant ay siyempre automatic din. tama sabi ni dieselNUBi, pigil ang acceleration, and turbo turns on at ~60kph. ang consumption ko sa fuel city is averaging at 9.5km/liter sa highway naman ay 11km/liter. actually kababalik ko lang from a long drive from Laoag City (Ilocos Norte), I've made three attempts para isagad ang ride ko, I just got 120kph at 3200 rpm.

    dieselNUBi, ano na ang naging top speed mo sa ride mo?

  6. Join Date
    Oct 2002
    Posts
    232
    #16
    Quote Originally Posted by dieselNUBI
    sky,

    Turbo does it job well... it turns on at 60

    but below 60... parang hirap tumakbo... pigiil ang feeling...
    also when running at medium speeds lets say 30-40, pag nag slow down, then when i try to accelerate again... ayun hirap arangkada...

    feeling ko un pagka pigil nang takbo ko makes it 7-8km/L
    No offense sa mga naka AT and turbo pero IMO parang hindi enough ang power increase ng turbo version ng XUV.

    Any HP firuges ng may turbo?

  7. Join Date
    Oct 2002
    Posts
    1,115
    #17
    sky,

    your right! low charged turbo for the XUV AT isnt enough...

    i just came from isuzu mla for 1st PMS
    i told them my complaints (high fuel consumption, low power)
    a adjust daw nila ang timing

    after the service, aba ang ganda na nang takbo... ndi na sya pigil...
    that was monday...

    tuesday i didnt use it
    now wednesday nun ginamit ko ganun nanaman... pigil ang takbo nya...

  8. Join Date
    Oct 2002
    Posts
    232
    #18
    Meron ba tayong Isuzu insider dito?

    Your comment will be appreciated.

    Thanks.

  9. Join Date
    Oct 2002
    Posts
    1,058
    #19
    dieselNUBI, pakidescribe nga in details ang pigil na sinasabi mo? kahit ba mas mabilis mong idiin ang aceelerator ay hindi pa rin hahatak? For my experience on my XUVi, if you press the accelerator deeper at a faster rate, the engine downshifts at 50kph (which bibilis ang hatak), then the turbo turns on at 63kph.

    Di ko lang alam kung 'yong pigil na sinasabi mo ay pareho tayo ng experience or normal sa XUVi A/T. Katatapos lang ang 5,000km PMS ko.

    By the way ano na ulit ang consumption mo sa fuel? Nag improve na ba from 7-8km/li to 9-10km/li city driving?

    BoknoyXTRM, comments please sa XUV or XUVi A/T on how they perform?

  10. Join Date
    Oct 2002
    Posts
    1,115
    #20
    20vanda01,

    from full stop... step on the gas... it will accelerate pero mabagal, at the same time maingay na ang engine ko (sounds like "eerrrrRRRRRR!!!" pero slowly accelerating lang ako...)

    when i had my 1500 PMS, i complained it. LOW POWER/HIGH FUEL CONSUMPTION! they said baka timing lang daw.. they will adjust it...
    when all was done. i drove it back home, ok na ang takbo... smooth! (hindi na pigil). then the engine is much much more quiet...

    after 2 days, balik ulet sa dati.
    so now alam ko talaga na may problem kasi na experience ko na ang magandang takbo with less noise in the engine...

    when im driving, hindi ko pinapa abot ng 2000rpm kasi maingay na talaga... my fuel consumption is still the same 7-8km/l...

    eto pa pala, when i was complaining sa isuzu personel, sabi ko "baket ganyan ang takaw sa krudo... hindi ako umaabot ng 300km sa full tank ko... mga syete lang sa isang litro! .... ilan ba talaga ang normal na fuel consumption nito para ma i kumpara ko sa akin?" then sabi ng isuzu personel... "mga ganyan nga! syete!!!"
    pucha, na asar ako dun eh ginaya lang nya sinabi ko. loko talaga un...

    babalik ako sa isuzu bukas... wish me luck! :wink:

Page 2 of 16 FirstFirst 12345612 ... LastLast
:: Isuzu Crosswind XUV(i), TXRM, XTO Discussion ::