New and Used Car Talk Reviews Hot Cars Comparison Automotive Community

The Largest Car Forum in the Philippines



Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 45
  1. Join Date
    Oct 2002
    Posts
    30
    #21
    ive heard about these cheater amps... hehe so currently i have an orion cobalt rated at 260/2 .. can i work with this?

  2. Join Date
    Oct 2002
    Posts
    6,797
    #22
    wow.oks yan.

  3. Join Date
    Oct 2002
    Posts
    30
    #23
    mga gurus, pano kong i wi wire tong orion ko to make it power an L7?

  4. Join Date
    Oct 2002
    Posts
    315
    #24
    ilang channel ba yung cobalt mo na amp? is it 4 channels? am not sure kung bridgeable....pero if it is bridgeable....go ahead......it gives your speakers more punch......pero if you can afford......try using Rockford Fosgate 1000.1 amps......be it two channel or one channel lang.......it would really bring out the peak power output ng L7's.......just like how I actually felt and heard in the last Transport Show sa megamall last time.......

  5. Join Date
    Oct 2002
    Posts
    30
    #25
    rf 1000.1 amps talaga balak ko eh, how much do these run here sa pinas? :D
    2 channel yung cobalt ko..

    but i have a bigger problem at hand..
    kasi i had my car repainted, so total stripdown, everything in the car was taken out.. eh hindi ko alam kung anong nangyari, at hindi gumagana subs ko nung binalik sa akin, so i tried to re wire it nalang myself, but then sobrang sabog nung subs! (2 ryan audio 12") :oops:

  6. Join Date
    Oct 2002
    Posts
    315
    #26
    rf 1000.1 amps run from 20,000 Php up.......

    reagarding your subs.....that really is a big problem......I have also brought my van to a 3-star motorshop to have it re-painted.....so before I brought it there....I had all my sound system set-up taken out.......my only advantage is.....kahit pagbali-baligtarin mo ang system ko.....I know how to put it back in order......

    why not try to analyze your system...what might be the main problem that causes your subs to make unnecessary noise......

  7. Join Date
    Oct 2002
    Posts
    30
    #27
    i know my system eh, pero the prob is after i re wired everything, sabog!
    its not noise eh, parang sobrang hindi kaya ng subs? or something kasi even at LOW volumes, nag c clip yung subs.. akala ko na reverse ko lang yung polarity at first, pero hindi rin eh..

  8. Join Date
    Oct 2002
    Posts
    315
    #28
    may tama na ba yung mga subs mo? check your power supply......or baka naman nabagsak ang subs mo.........

  9. Join Date
    Oct 2002
    Posts
    30
    #29
    i dont think nabagsak eh..
    what about the power supply? yung subs lang talaga eh
    my seps are fine..
    hmm..
    wala pa namang tama subs ko

  10. Join Date
    Oct 2002
    Posts
    315
    #30
    are your subs enclosed? check mo.....then check the amp that runs the subs.....baka dun nanggagaling ang clipping....

Page 3 of 5 FirstFirst 12345 LastLast
what amp?