New and Used Car Talk Reviews Hot Cars Comparison Automotive Community

The Largest Car Forum in the Philippines



Results 1 to 4 of 4
  1. Join Date
    May 2011
    Posts
    108
    #1
    hi, had my tucson for 4 months now. After its 5k PMS, there's this strange odor coming from the A/C upon starting the engine. But it disappears after a few seconds. The smell is like "Patis" or something similar.
    Also this only happens after the car has been idle for quite some time, 2+ hours.

  2. Join Date
    Feb 2009
    Posts
    5,010
    #2
    Quote Originally Posted by providence View Post
    hi, had my tucson for 4 months now. After its 5k PMS, there's this strange odor coming from the A/C upon starting the engine. But it disappears after a few seconds. The smell is like "Patis" or something similar.
    Also this only happens after the car has been idle for quite some time, 2+ hours.

    the smell is coming from the aluminum cooling fins of the evaporator. the drain hole might be plugged up and the condensate has accumulated up to it

  3. Join Date
    May 2011
    Posts
    108
    #3
    Quote Originally Posted by jick.cejoco View Post
    the smell is coming from the aluminum cooling fins of the evaporator. the drain hole might be plugged up and the condensate has accumulated up to it
    Thanks for the reply. What can I do about it? Send it to casa?
    Also, its plugged up only after 4months?

  4. Join Date
    Feb 2009
    Posts
    5,010
    #4
    Quote Originally Posted by providence View Post
    Thanks for the reply. What can I do about it? Send it to casa?
    Also, its plugged up only after 4months?
    there is a possibility it is clogged up. we are in a tropical area and insects, mud bees to be specific like holes smaller than 1 inch to build as nests. you can try clearing it up by using s stiff bush cutter line or thick fishing line probing into the drain hole

Weird odor when starting the engine