New and Used Car Talk Reviews Hot Cars Comparison Automotive Community

The Largest Car Forum in the Philippines



Page 260 of 329 FirstFirst ... 160210250256257258259260261262263264270310 ... LastLast
Results 2,591 to 2,600 of 3286
  1. Join Date
    Oct 2002
    Posts
    17,335
    #2591
    [QUOTE=cocoy_g;2636259]
    Quote Originally Posted by vinj View Post
    Replaced the front shocks of my Gen 10.5 (55,000kms). KYB Excel G's cost P 3,250.00 per piece at Toyorama. I forgot how smooth the Altis can be. :D

    Sir Vinj, shocks lang po ba pinalitan niyo at dapat may iba pang mga parts ang sinasabay kapag papalit ng shocks? At sa Toyorama niyo rin po ba pinalitan ng shocks?
    Pasensya na po sa mga newbie questions. Salamat.
    Shocks lang pinalitan. All other parts are a-okay. I had the work done at Motech in Pampanga as that's where i go for general service of all our rides. You can try Wheelers Suspension Haus in Banawe (N. Roxas St.).

    We're selling our Gen 10.5 so i'll be replacing the rear shocks too, before the car finds a new owner.
    Last edited by vinj; November 2nd, 2015 at 03:59 PM.

  2. Join Date
    Feb 2008
    Posts
    9,206
    #2592
    [quote=vinj;2636478]
    Quote Originally Posted by cocoy_g View Post

    Shocks lang pinalitan. All other parts are a-okay. I had the work done at Motech in Pampanga as that's where i go for general service of all our rides. You can try Wheelers Suspension Haus in Banawe (N. Roxas St.).

    We're selling our Gen 10.5 so i'll be replacing the rears too, before the car finds a new owner.
    decided ka na on which to get? baka you can extend the budget a bit. si CVT nakakuha na ng MS hehe

  3. Join Date
    Feb 2008
    Posts
    9,206
    #2593
    -------------------

  4. Join Date
    Oct 2002
    Posts
    17,335
    #2594
    [QUOTE=crazy_boy;2636488]
    Quote Originally Posted by vinj View Post

    decided ka na on which to get? baka you can extend the budget a bit. si CVT nakakuha na ng MS hehe
    I'll decide when the time comes (meaning pag nabenta na si Altis. )

    Wala pa ako sa level ni CVT. Baka dun sa pick-up, if not dun ako sa entry-level hatchback if i get to close the deal with my tita for her old CRDi. ;)

  5. Join Date
    Nov 2015
    Posts
    12
    #2595
    Hi ask ko lang po sa mga naka 10.5 gen na altis nagkaroon po ba ng problem yun steering nyo? yun kapag kinakabig mo me tunog at kapag rough road e me kalampag sound? pinacheck ko kasi dati steering shaft daw problem then dinala ko sa toyota quezon ave kasi nakita ko me recall pero ayaw nila aminin kelangan pa daw investigation etc..

    ngaun balak ko na sana ipagawa kasi bebenta ko na.. me alam po kayo nagaayos or saang toyota ko dapat dalhin pare irepair nila?

    thanks!

    - - - - - - - - - - - - - - - - - - - - - -

    Hi ask ko lang po sa mga naka 10.5 gen na altis nagkaroon po ba ng problem yun steering nyo? yun kapag kinakabig mo me tunog at kapag rough road e me kalampag sound? pinacheck ko kasi dati steering shaft daw problem then dinala ko sa toyota quezon ave kasi nakita ko me recall pero ayaw nila aminin kelangan pa daw investigation etc..

    ngaun balak ko na sana ipagawa kasi bebenta ko na.. me alam po kayo nagaayos or saang toyota ko dapat dalhin pare irepair nila?

    thanks!

  6. Join Date
    Oct 2006
    Posts
    261
    #2596
    Madami possible causes, yung sakin pinalitan ko muna mga ball joint, tie rod end at stab link. Nung andun pa din pinalitan ko naman ng cv joint at rack & pinion (mahal na). Dun nawala yung kalampag.

  7. Join Date
    Oct 2002
    Posts
    17,335
    #2597
    Quote Originally Posted by vur18 View Post

    Hi ask ko lang po sa mga naka 10.5 gen na altis nagkaroon po ba ng problem yun steering nyo? yun kapag kinakabig mo me tunog at kapag rough road e me kalampag sound? pinacheck ko kasi dati steering shaft daw problem then dinala ko sa toyota quezon ave kasi nakita ko me recall pero ayaw nila aminin kelangan pa daw investigation etc..

    ngaun balak ko na sana ipagawa kasi bebenta ko na.. me alam po kayo nagaayos or saang toyota ko dapat dalhin pare irepair nila?

    thanks!
    The common issue is the rack and pinion, and possibly busted/weak shock absorbers. If you unit is still under warranty then have it replaced as that part costs 24K out of the CASA (and around 18K in Banawe for brand new original). Surplus is around 8K including installation but you wont be sure how long it will last. Try another dealer beside TQA as i hear not-so-good stories before about their service. I personally went to Toyota North EDSA and Shaw before and was satisfied with their service.

    In the case of my 2012 GEn 10.5, the problem came out after 50,000kms. As i was out of warranty, i decided to try first a surplus unit. It got lessened (particularly the tok sound when turning) but the light "thug" sound on uneven pavement went away completely when i changed to new KYB gas shocks.

    Sold my unit just last week and the new owner found the suspension to be very solid when he tested it, as compared to the other Gen 10.5's they checked out (with even lower mileage).
    Last edited by vinj; November 10th, 2015 at 09:23 AM.

  8. Join Date
    Nov 2015
    Posts
    12
    #2598
    hmmm san ko po pwd i pa repair if ever? and pwd ko ba sya ibenta din ng as is? or walang bibili pag nadiscover nila na me prob?

    lumalabas lang kasi sya kapag rough road pag smooth naman un kalsada wala ako naririnig..

    - - - - - - - - - - - - - - - - - - - - - -

    hmmm san ko po pwd i pa repair if ever? and pwd ko ba sya ibenta din ng as is? or walang bibili pag nadiscover nila na me prob?

    lumalabas lang kasi sya kapag rough road pag smooth naman un kalsada wala ako naririnig..

  9. Join Date
    Jul 2007
    Posts
    46,052
    #2599
    Finally gonna have my 40k oil change!

    Last edited by _Cathy_; November 12th, 2015 at 12:23 AM.

  10. Join Date
    Aug 2012
    Posts
    345
    #2600
    Anybody here who experienced their ALTIS not starting? I experienced it this morning and it's kind of weird, parang walang redondo, tried it I think more than 5 times, the lights are flickering in the cabin. I tried it again a couple of times and until such time na parang na discharge na battery, afterwards dun pa nag start. the MID reading was reset, except the radio.

    Went to casa afterwards to have it checked, but unfortunately the problem was gone or should I say the car would start in just one click. Hayyyyyyyyyy ano kaya problem nito? Anybody here who has experienced the same thing and what was the real problem and solution would be greatly appreciated. TIA

    - - - - - - - - - - - - - - - - - - - - - -

    Anybody here who experienced their ALTIS not starting? I experienced it this morning and it's kind of weird, parang walang redondo, tried it I think more than 5 times, the lights are flickering in the cabin. I tried it again a couple of times and until such time na parang na discharge na battery, afterwards dun pa nag start. the MID reading was reset, except the radio.

    Went to casa afterwards to have it checked, but unfortunately the problem was gone or should I say the car would start in just one click. Hayyyyyyyyyy ano kaya problem nito? Anybody here who has experienced the same thing and what was the real problem and solution would be greatly appreciated. TIA

Toyota Corolla 10th Generation Altis Owners [continued]