New and Used Car Talk Reviews Hot Cars Comparison Automotive Community

The Largest Car Forum in the Philippines



Page 143 of 177 FirstFirst ... 4393133139140141142143144145146147153 ... LastLast
Results 1,421 to 1,430 of 1770
  1. Join Date
    May 2009
    Posts
    119
    #1421
    Quote Originally Posted by ovitrops View Post
    jaz014, ano year model ng ride nyo? puwedeng reason kasi ng pagtaas ng temp gauge is may bara na sa radiator niyo. Every 20,000 km dapat pinapalitan ang coolant, baka hindi napalitan ng ganung frequency yung sa inyo..
    sir its a 05 XT bale sir newly overhauled ang radiator and with 1 blocked hole on the radiator due to leak(is this causing high temp). Coolant was only used last Feb and before magcoolant nag radiator flush using prestone radiator flush...one thing i am noticing with my ride kahit i-rev ng high rpm walang black smoke na lumalabas...

  2. Join Date
    Apr 2010
    Posts
    2
    #1422
    need help sir? napansin ko lang sa ride ko ( xuvi 02 matic) biglang nagbabago ang takbo, sa coastal hirap syang tumakbo sa 60 kph at 3000rpm di na sya maka angat sa 80kph pero minsan naman ok sya sa takbo na 60-80 * 2000 rpm.sabi nang barkada ko baka raw nag slide ung clutch..un ba ang depekto nito??thanks

  3. Join Date
    May 2010
    Posts
    6
    #1423
    Quote Originally Posted by jaz014 View Post
    sir its a 05 XT bale sir newly overhauled ang radiator and with 1 blocked hole on the radiator due to leak(is this causing high temp). Coolant was only used last Feb and before magcoolant nag radiator flush using prestone radiator flush...one thing i am noticing with my ride kahit i-rev ng high rpm walang black smoke na lumalabas...
    Sir sorry for the late reply, nasira server ng internet namin. Ang mga na experience ko lang na mga dahilan ng pagtaas ng temp gauge sa sasakyan are:
    1. Sira nang thermostat;
    2. Baradong radiator;
    3. Sirang radiator fan motor; at
    4. Sirang water pump.
    In your case, mukhang ayos naman lahat ng mga parts na sinabi ko. Yung mga nabanggit kong parts, nasira within the range of 5 years.

    Reviewing the facts, hindi nagabawas water coolant niyo, at kakalagay niyo lang ng oil sa fan.. hindi kaya faulty yun water pump na newly installed, which was put to the test nung matinding traffic sa init at babad makina? These are just my opinion from experience sir, hindi ako expert dito..

  4. Join Date
    May 2010
    Posts
    6
    #1424
    Quote Originally Posted by jaz014 View Post
    sir its a 05 XT bale sir newly overhauled ang radiator and with 1 blocked hole on the radiator due to leak(is this causing high temp).
    Sir, most probably yung baradong hole sa radiator ang nag-cause ng pagtaas ng temp gauge..

  5. Join Date
    Sep 2009
    Posts
    4,593
    #1425
    ano naman reason pag bumababa rpm pag naka idle? yung xto ko minsan 600rpm lang with ac on. madalas tuloy ako mamatayan sa daan. comments please! thanks!

  6. Join Date
    Feb 2005
    Posts
    2,642
    #1426
    Quote Originally Posted by watuzi View Post
    need help sir? napansin ko lang sa ride ko ( xuvi 02 matic) biglang nagbabago ang takbo, sa coastal hirap syang tumakbo sa 60 kph at 3000rpm di na sya maka angat sa 80kph pero minsan naman ok sya sa takbo na 60-80 * 2000 rpm.sabi nang barkada ko baka raw nag slide ung clutch..un ba ang depekto nito??thanks
    Madali naman ma-determine kung clutch slide ka. You would notice it when you shift gears, matagal bago kumagat yung gears. Also, when was the last time you had your car PMS? Sa casa ba o sa mosquito shop lang?

    Quote Originally Posted by holdencaulfield View Post
    ano naman reason pag bumababa rpm pag naka idle? yung xto ko minsan 600rpm lang with ac on. madalas tuloy ako mamatayan sa daan. comments please! thanks!
    It could be a faulty idle up switch. The said switch is to regulate the idle when load (particularly gear shift/aircon compressor) engages.

  7. Join Date
    Apr 2010
    Posts
    2
    #1427
    sir! ngaun lang kasi ko naka pag drive ng matic kaya di ko pa pansin ang pag shift ng gears..pero nararamdaman ko lang na parang me natulak sa likod ko pag nag change ng gears 1st and 2nd lang kaso ung third and fourth parang wala na..sa barkada ko kasi itong crosswind kaya di ko alam kung san sya nag papagawa ako lang ang gumagamit. san ba malapit na casa dito sa makati area ako.

  8. Join Date
    Apr 2010
    Posts
    23
    #1428
    Quote Originally Posted by TholitzReloaded View Post
    Sinabi mo pa, Day 22 na ngayun wala parin yung Parts na kailangan ko (Headlamp) puro sila next week di masabi kung kailan exactly darating yung parts. Ni hindi apologetic yung nakausap ko tumawag nalng daw ulit ako sa Monday para magfollowup.. Imagine, nakakapiss off talaga yung mga tao dito. I wouldn't recommend this casa to any owner of Isuzu Cars here in Tsikot.

    Bagsak talaga Customer Service nila dito, they couldn't do anything para maprovide yung parts and to think na they knew the parts needed for replacement from the moment na dinala ko sa kanila yung auto ko as early as April 28 lumabas ung LOA and naorder na raw yung Parts pero anong petsa na ngaun May 12 na wala parin. Di man lang masabi ng taong kausap ko what's causing the delay.
    Nako sir ako ren marameng bad experience sa Isuzu Pasig

  9. Join Date
    Feb 2005
    Posts
    2,642
    #1429
    Quote Originally Posted by watuzi View Post
    sir! ngaun lang kasi ko naka pag drive ng matic kaya di ko pa pansin ang pag shift ng gears..pero nararamdaman ko lang na parang me natulak sa likod ko pag nag change ng gears 1st and 2nd lang kaso ung third and fourth parang wala na..sa barkada ko kasi itong crosswind kaya di ko alam kung san sya nag papagawa ako lang ang gumagamit. san ba malapit na casa dito sa makati area ako.
    ISUZU Makati
    Dominga Building III, 2113 Pasong Tamo corner Dela Rosa Street, Makati City
    CONTACT NUMBERS
    Trunkline : 8191213 / 8191219 / 893-8064 / 893-8048 / 8938047

  10. Join Date
    Sep 2009
    Posts
    4,593
    #1430
    Quote Originally Posted by Benzmizer View Post
    It could be a faulty idle up switch. The said switch is to regulate the idle when load (particularly gear shift/aircon compressor) engages.
    *benzmizer-can i use this tiny li'l knob at the lower left to correct the rpm? btw, if my idle up switch is faulty, won't it move? coz i observe that the needle drops to 500rpm when load disengages and shoots up to 600rpm only when load engages. thanks again!

Tags for this Thread

Isuzu Crosswind Owners Thread [ARCHIVED]