New and Used Car Talk Reviews Hot Cars Comparison Automotive Community

The Largest Car Forum in the Philippines



Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 33
  1. Join Date
    Nov 2003
    Posts
    3,849
    #21
    a faulty fuel filter will not result in a cel.

  2. Join Date
    Dec 2003
    Posts
    11,317
    #22
    my CEL is also lit, discovered a loose fuel cap but still waiting for the CEL to turn off aarrgggghhhhh

  3. #23
    Quote Originally Posted by BlueBimmer
    my CEL is also lit, discovered a loose fuel cap but still waiting for the CEL to turn off aarrgggghhhhh
    try and reset the ECU. Normally there is a fuse that you can remove for say, 1-2 mins and this will reset the ECU

  4. Join Date
    Dec 2003
    Posts
    11,317
    #24
    Quote Originally Posted by garyq
    try and reset the ECU. Normally there is a fuse that you can remove for say, 1-2 mins and this will reset the ECU
    thanks for the tip!

  5. Join Date
    Nov 2003
    Posts
    3,849
    #25
    that doesn't work for bimmers imo. you really need a reset tool to do that.

    bluebimmer, if you want pass by the shop and we'll see what we can do about your service/cel light

  6. Join Date
    Jul 2004
    Posts
    439
    #26
    To Mr. speedyfix:

    At last. May obdII scanner na kayo. Is it a LAUNCH computer?

    How much do you charge for it?

    Does it have an adaptor for a GM car such as my Zafira? My check light lights up every once in a while but eventually turns off. If ever something really goes wrong, I want to know if you can help me... Thanks..

  7. Join Date
    Apr 2006
    Posts
    164
    #27
    same goes to me...

    starting the engine is normal...but when im driving...maybe a 3kms and more. the check engine will lights on?? do you know whats wrong?

    my speedometer is not moving? is it related? does speedometer have fuse? (if, yes where??)
    thanx

  8. Join Date
    Nov 2003
    Posts
    3,849
    #28
    edl, yup it's a launch. normally we check muna what the problem is then depending on what is done that's when we say what the charge will be. if it's just a reset that's needed then di ganun kamahal

    kabuke0, replace your speed sensor. it's throwing a CEL code kaya umiilaw yung cel mo.

  9. Join Date
    Jul 2004
    Posts
    439
    #29
    Quote Originally Posted by speedyfix
    edl, yup it's a launch. normally we check muna what the problem is then depending on what is done that's when we say what the charge will be. if it's just a reset that's needed then di ganun kamahal

    LAUNCH X431. Touch screen with built-in printer. One of the best OBDII on the market. Expert na ako sa launch since my W210 always uses it.

  10. Join Date
    Nov 2003
    Posts
    3,849
    #30
    that's it!

Page 3 of 4 FirstFirst 1234 LastLast
Check Engine light is on recommend a shop