New and Used Car Talk Reviews Hot Cars Comparison Automotive Community

The Largest Car Forum in the Philippines



Page 1 of 76 123451151 ... LastLast
Results 1 to 10 of 754
  1. Join Date
    Jul 2007
    Posts
    50,099
    #1
    My car is a 1996 Corolla GLi. The car is seldom used and the battery has been drained and recharged several times already since I got it in 2009. The last time the battery was recharged was about a month or two ago. Since then the car gets started for about 5 minutes daily. However during the past few days, the battery indicator would still light up even when the car is started. Now I am not sure if I only need to buy a new battery or there could be a deeper problem? The Motolite guy mentioned that there is ground(?) in the battery, I am not sure if I remember it correctly though. I should have the alternator checked daw.

    In 2011, I already had the distributor assembly replaced at Tower of David. My car also has an AC problem, it stops blowing cold air in slow traffic or idling. But when it's running fast, it works just fine. There are times when the AC is really cold but often times it's almost just fan. I already had the compressor replaced (original Denso) in 2008 and it cost me 15k!!! I am not sure if all these problems are connected.

    Please help me identify my car's problem as I want to have an idea on what needs to get fixed. Also, does anyone know the new contact number of Tower of David? They moved their shop na kasi in Pasong Tamo. I would also appreciate other shop recommendations in Makati or Paranaque area. Thanks!

  2. Join Date
    Oct 2002
    Posts
    29,320
    #2
    Quote Originally Posted by Cathy_for_you View Post
    My car is a 1996 Corolla GLi. The car is seldom used and the battery has been drained and recharged several times already since I got it in 2009. The last time the battery was recharged was about a month or two ago. Since then the car gets started for about 5 minutes daily. However during the past few days, the battery indicator would still light up even when the car is started. Now I am not sure if I only need to buy a new battery or there could be a deeper problem? The Motolite guy mentioned that there is ground(?) in the battery, I am not sure if I remember it correctly though. I should have the alternator checked daw.
    It could be a dead/dying battery or one of the battery terminals could be loose or corroded. Generally a car battery that reaches a fully drained state gets damage on its plates by action of the lead sulfate. Although a single full drain will not destroy a battery, several times could kill it. The battery could also not be charging up because of a loose battery terminal or due to the corrosion between the battery terminal and battery post. If you can see corrosion (looks like white powder) at the battery post, remove the battery terminal and clean off the white powder with water & a cleaning brush. Assuming the alternator is working fine, the battery should charge up normally.


    In 2011, I already had the distributor assembly replaced at Tower of David. My car also has an AC problem, it stops blowing cold air in slow traffic or idling. But when it's running fast, it works just fine. There are times when the AC is really cold but often times it's almost just fan. I already had the compressor replaced (original Denso) in 2008 and it cost me 15k!!! I am not sure if all these problems are connected.
    problems NOT connected. Your AC not blowing cold all the time could be an indication of low freon levels in your car aircon. That in turn would show that car AC has a slow leak. Have your car brought to a car AC specialist to be checked and freon refilled. Hopefully the leak is from a loose fitting only.

  3. Join Date
    Feb 2009
    Posts
    5,010
    #3
    Quote Originally Posted by Cathy_for_you View Post
    My car is a 1996 Corolla GLi. The car is seldom used and the battery has been drained and recharged several times already since I got it in 2009. The last time the battery was recharged was about a month or two ago. Since then the car gets started for about 5 minutes daily. However during the past few days, the battery indicator would still light up even when the car is started. Now I am not sure if I only need to buy a new battery or there could be a deeper problem? The Motolite guy mentioned that there is ground(?) in the battery, I am not sure if I remember it correctly though. I should have the alternator checked daw.

    In 2011, I already had the distributor assembly replaced at Tower of David. My car also has an AC problem, it stops blowing cold air in slow traffic or idling. But when it's running fast, it works just fine. There are times when the AC is really cold but often times it's almost just fan. I already had the compressor replaced (original Denso) in 2008 and it cost me 15k!!! I am not sure if all these problems are connected.

    Please help me identify my car's problem as I want to have an idea on what needs to get fixed. Also, does anyone know the new contact number of Tower of David? They moved their shop na kasi in Pasong Tamo. I would also appreciate other shop recommendations in Makati or Paranaque area. Thanks!


    your battery has a shelf life and useful life. they don't last forever. it might be at the end of its road. have the parasitic drain checked too. your battery store should be able to do the battery test, charging rate test and parasitic drain test. if they can't do this or can't do this properly, look for a better battery store.
    as far as the airconditioner/climate control, the idle speed maybe too low and/or the condenser fan might have insufficient airflow across the condenser.. check the idle speed (around 750 in neutral at idle), also test the a/c by simulating the ram air using an electric fan blowing straight through the condenser. have the technician use a thermometer in the vent register and have him read the pressures both suction (low side) and discharge (high side). your low shide should be around 29 to 35 psig at idle and the high side around 275 to 300 depending on ambient temperature and airflow across the condenser
    Last edited by jick.cejoco; June 4th, 2013 at 11:42 AM.

  4. Join Date
    Jan 2004
    Posts
    6,422
    #4
    based on experience: lit battery indicator even when the engine is running is a sign of a busted alternator

  5. Join Date
    Jun 2011
    Posts
    4,509
    #5
    C4U.... regarding your battery... pwedeng problem lies on your alternator... ayaw na mag charge kaya may red battery signal.....

    or sabi kamo ng bat. techinician... grounded? grounded na yung battery mo....

    sa aircon naman.... kung 1996 na yung car mo... most probably you need to replace your condenser na, nagbabara na mga tubes nun... or it should be cleaned internally... iisa nga lang shop ang alam ko na pwedeng malinis ng mabuti nyan... sa Q.C. pa yun... near mindanao ave.. EDS car aircon...

    or check mo A.C. AUX FAN....

    low freon pwede din... baka hindi yun ang problema at normal naman pag tumatakbo na....

  6. Join Date
    Jul 2007
    Posts
    50,099
    #6
    Alternator problem nga ang kinakatakot ko :nerves: Yan na lang kasi ang wala pang nagiging sira since we bought the car.

    I don't remember what the Motolite guy said but I think he said grounded nga ata or may problem kaya parating nagdi diskarga yung battery.
    Last edited by _Cathy_; June 4th, 2013 at 11:49 AM.

  7. Join Date
    Oct 2011
    Posts
    26,770
    #7
    ^

    mahal din alternator. ung sakn dati akala alternator mismo ang sira un pala ung pulley lang kailangan palitan.

  8. Join Date
    Feb 2009
    Posts
    5,010
    #8
    Quote Originally Posted by Cathy_for_you View Post
    Alternator problem nga ang kinakatakot ko :nerves: Yan na lang kasi ang wala pang nagiging sira since we bought the car.

    I don't remember what the Motolite guy said but I think he said grounded nga ata or may problem kaya parating nagdi diskarga yung battery.


    don't jump into conclusions. don't believe hearsay. don't rely on personal anecdotes. have a true diagnostics done. numbers don't lie. numbers are quantifiable. as long as the gauges and test instruments are reliable, they don't lie. the symptoms your car have are routine maintenance items and not rocket science.

  9. Join Date
    Mar 2013
    Posts
    3,648
    #9
    Quote Originally Posted by Cathy_for_you View Post
    Alternator problem nga ang kinakatakot ko :nerves: Yan na lang kasi ang wala pang nagiging sira since we bought the car.

    I don't remember what the Motolite guy said but I think he said grounded nga ata or may problem kaya parating nagdi diskarga yung battery.
    Pa check mo muna kung charging pa alternator mo.

  10. Join Date
    Oct 2011
    Posts
    26,770
    #10
    ^

    kung grounded, electricians have a way of testing to verify na grounded nga kaya na dr-drain baterya. It is just a matter of finding knug ano ang nag cause nun.

Page 1 of 76 123451151 ... LastLast

Tags for this Thread

How to Know If It Is Only A Battery Problem